WARNING! We will be changing to infinitygaming1.yolasite.com soon!

We make games... Of course.

You will need Blender 2.49b or 2.5 to play games. You can get it at www.blender.org

2.5 games will not run in blenderplayer.exe because the player still has bugs. Run them with 2.5.

Phone: ?
Fax: ?
Email: blackcatgamesunlimited@gmail.com

Welcome to the BCGU site!

Make a Free Website with Yola.